HalloweenBot - Countdown Spam โ€“ Incident details

Countdown Spam

Resolved
Partial outage 10 %
Started about 2 months agoLasted about 2 hours

Affected

Clients

Degraded performance from 12:59 PM to 1:48 PM, Partial outage from 1:48 PM to 2:36 PM

HalloweenBot

Degraded performance from 12:59 PM to 1:48 PM, Partial outage from 1:48 PM to 2:36 PM

Slash Commands

Degraded performance from 12:59 PM to 1:48 PM, Partial outage from 1:48 PM to 2:36 PM

Prefix Commands

Degraded performance from 12:59 PM to 1:48 PM, Partial outage from 1:48 PM to 2:36 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We have identified the cause of the recent dispatch issues triggered by timezone handling during the BST โ†’ GMT transition.

    A patch has now been deployed, and normal operation has been restored.

    We are currently monitoring the system closely to ensure everything remains stable.

    Summary:

    - โœ… Issue identified and resolved

    - โœ… Patch deployed successfully

    - ๐Ÿ” Live monitoring ongoing

    โ€” HalloweenBot Team ๐ŸŽƒ

  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating

    We are aware of an issue that is causing the countdown to keep sending on startup. This issue seems to be with it not saving the time it sent to the database correctly we are actively investigating this issue to find the root cause.

    Apologies for any inconvenience during this time.